1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
7 pkgdesc="a simple thesaurus"
9 url="https://hunspell.github.io/"
11 depends=('glibc' 'perl')
12 makedepends=('hunspell')
14 source=(https://downloads.sourceforge.net/hunspell/${pkgname/lib/}-${pkgver}.tar.gz)
15 sha512sums=('a04da39812bcfb1391a2cba7de73e955eafe141679ec03ed6657d03bebf360b432480d0037dff9ed72a1dfda5a70d77d44ac2bb14cdb109fd8e2a38376feee21')
18 cd "${pkgname/lib/}"-$pkgver
19 ./configure --prefix=/usr --disable-static
24 cd "${pkgname/lib/}"-$pkgver
25 # run the example program:
26 ./example th_en_US_new.idx th_en_US_new.dat checkme.lst
27 # run the example program with stemming and morphological generation:
28 # e.g. to check mouse, mice, rodents, eats, eaten, ate, eating etc. words
29 ./example morph.idx morph.dat morph.lst morph.aff morph.dic
33 cd "${pkgname/lib/}"-$pkgver
34 make DESTDIR="$pkgdir" install
36 install -Dm644 "${srcdir}"/${pkgname/lib/}-$pkgver/COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING