archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libvpx / repos / extra-x86_64 / PKGBUILD
blob36dc2414de5fce9a241835165cfe02a949900899
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
5 pkgname=libvpx
6 pkgver=1.11.0
7 pkgrel=2
8 pkgdesc='VP8 and VP9 codec'
9 arch=(x86_64)
10 url=https://www.webmproject.org/
11 license=(BSD)
12 depends=(gcc-libs)
13 makedepends=(
14   git
15   nasm
17 provides=(libvpx.so)
18 _tag=626ff35955c2c35b806b3e0ecf551a1a8611cdbf
19 source=(git+https://chromium.googlesource.com/webm/libvpx#tag=${_tag})
20 sha256sums=(SKIP)
22 pkgver() {
23   cd libvpx
25   git describe --tags | sed 's/^v//'
28 build() {
29   cd libvpx
31   CFLAGS+=' -ffat-lto-objects'
32   CXXFLAGS+=' -ffat-lto-objects'
34   ./configure \
35     --prefix=/usr \
36     --disable-install-docs \
37     --disable-install-srcs \
38     --enable-pic \
39     --enable-postproc \
40     --enable-runtime-cpu-detect \
41     --enable-shared \
42     --enable-vp8 \
43     --enable-vp9 \
44     --enable-vp9-highbitdepth \
45     --enable-vp9-temporal-denoising
46   make
49 package() {
50   cd libvpx
52   make DIST_DIR="${pkgdir}"/usr install
53   install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/libvpx/
56 # vim: ts=2 sw=2 et: