db-move: moved webkitgtk-6.0 from [testing] to [extra] (x86_64)
[arch-packages.git] / qqc2-desktop-style / trunk / PKGBUILD
blobda62521256a2aa773a57c12a86f2980b72b06bc9
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=qqc2-desktop-style
4 pkgver=5.105.0
5 pkgrel=1
6 pkgdesc='A style for Qt Quick Controls 2 to make it follow your desktop theme'
7 arch=(x86_64)
8 url='https://community.kde.org/Frameworks'
9 license=(LGPL)
10 groups=(kf5)
11 depends=(kirigami2 kiconthemes sonnet)
12 makedepends=(extra-cmake-modules)
13 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('de8f6c8b6a9af2caecfea20f71d84a791e6f685b8b6048668ed22a0d25121a92'
15             'SKIP')
16 validpgpkeys=('53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB') # David Faure <faure@kde.org>
18 build() {
19   cmake -B build -S $pkgname-$pkgver \
20     -DBUILD_TESTING=OFF
21   cmake --build build
24 package() {
25   DESTDIR="$pkgdir" cmake --install build