1 # Maintainer: Gaetan Bisson <bisson@archlinux.org>
2 # Contributor: kevin <kevin@archlinux.org>
3 # Contributor: John Proctor <jproctor@prium.net>
8 pkgdesc='Graph visualization software'
9 url='https://www.graphviz.org/'
12 depends=('libltdl' 'gd' 'librsvg' 'ghostscript' 'pango' 'gts' 'gsfonts')
13 makedepends=('swig' 'mono' 'guile' 'lua' 'ocaml>=4.14.0' 'perl' 'python' 'r' 'tk' 'qt6-base' 'gtk2')
14 optdepends=('mono: sharp bindings'
15 'guile: guile bindings'
17 'ocaml: ocaml bindings'
19 'python: python bindings'
23 'gtk2: gtk output plugin'
25 source=("https://gitlab.com/graphviz/graphviz/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
26 'ghostscript918.patch')
27 sha256sums=('dd06f45f5bbcb1c7cbc67adab5359da2cd4b40533dc7c7424b3fc0e998bbd6c9'
28 '0083d126e27f2223ec4226fc1d71c9c84106968a0fdf65de838aee1e4882bfdb')
32 cd "${srcdir}/${pkgname}-${pkgver}"
33 patch -p1 -i ../ghostscript918.patch
38 cd "${srcdir}/${pkgname}-${pkgver}"
40 export CXXFLAGS+=' -fPIC -fpermissive'
42 ./configure --prefix=/usr \
43 --enable-python3=yes --disable-python --enable-lefty
44 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # Fix overlinking
49 cd "${srcdir}/${pkgname}-${pkgver}"
50 make DESTDIR="${pkgdir}" install
52 # fix symlink to symlink that doesn't get picked up by makepkg's zipman
53 ln -s gv2gxl.1.gz "${pkgdir}"/usr/share/man/man1/dot2gxl.1.gz
54 rm "${pkgdir}"/usr/share/man/man1/dot2gxl.1
56 # Deduplicates TCL libraries
57 cd "${pkgdir}/usr/lib/tcl8.6"
59 ln -s ../graphviz/tcl graphviz