archrelease: copy trunk to testing-x86_64
[arch-packages.git] / kapidox / trunk / PKGBUILD
bloba4ff7ea3dd274047895877f340bda712fb77d519
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kapidox
6 pkgver=5.105.0
7 pkgrel=2
8 pkgdesc='Frameworks API Documentation Tools'
9 arch=(any)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(python-jinja python-yaml)
13 makedepends=(python-build python-installer python-wheel python-setuptools qt5-base)
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('68f1e1d617c9d9a661dd630bdf3f1659c4619e6f08c7e0afbbb37270fa52a125'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
20 build() {
21   cd $pkgname-$pkgver
22   python -m build --wheel --no-isolation
25 package() {
26   cd $pkgname-$pkgver
27   python -m installer --destdir="$pkgdir" dist/*.whl