sbcl rebuild
[arch-packages.git] / libnice / trunk / PKGBUILD
blob9f34f5574f2c36d2e37c05d35ec2c9a0cbeea992
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: William Díaz <wdiaz@archlinux.us>
5 pkgname=libnice
6 pkgver=0.1.19
7 pkgrel=1
8 pkgdesc="An implementation of the IETF's draft ICE (for p2p UDP data streams)"
9 url="https://nice.freedesktop.org"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(glib2 gnutls gupnp-igd)
13 makedepends=(gstreamer gtk-doc git meson gobject-introspection graphviz)
14 optdepends=('gstreamer: "nice" GStreamer plugin')
15 provides=(libnice.so)
16 options=(debug)
17 _commit=64ef27e4847016568985f0f3c1fe4a4fb632e408  # tags/0.1.19^0
18 source=("git+https://gitlab.freedesktop.org/libnice/libnice.git#commit=$_commit")
19 sha256sums=('SKIP')
21 pkgver() {
22   cd libnice
23   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd libnice
30 build() {
31   arch-meson libnice build -D gtk_doc=enabled
32   meson compile -C build
35 check() {
36   meson test -C build --print-errorlogs
39 package() {
40   meson install -C build --destdir "$pkgdir"