sbcl rebuild
[arch-packages.git] / pangomm / trunk / PKGBUILD
blob52f2ea00cd9016d660ceda160799a3eda9c3b3a3
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgbase=pangomm
5 pkgname=(pangomm pangomm-docs)
6 pkgver=2.46.2
7 pkgrel=1
8 pkgdesc="C++ bindings for Pango"
9 url="https://www.gtkmm.org/"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(pango glibmm cairomm)
13 makedepends=(git meson mm-common glibmm-docs cairomm-docs)
14 options=(!emptydirs)
15 _commit=c531ef7cf5351ec14014da2480b2fd3e474eac00  # tags/2.46.2^0
16 source=("git+https://gitlab.gnome.org/GNOME/pangomm.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd pangomm
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd pangomm
28 build() {
29   arch-meson pangomm build -D maintainer-mode=true
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package_pangomm() {
38   depends+=(libsigc-2.0.so libglibmm-2.4.so libcairomm-1.0.so)
39   provides=(libpangomm-1.4.so)
41   meson install -C build --destdir "$pkgdir"
43   # Split -docs
44   mkdir -p docs/usr/share
45   mv -t docs/usr/share "$pkgdir"/usr/share/{devhelp,doc}
48 package_pangomm-docs() {
49   pkgdesc+=" (documentation)"
50   depends=()
51   options=(!strip)
53   mv -t "$pkgdir" docs/*