archrelease: copy trunk to extra-x86_64
[arch-packages.git] / clutter-gtk / trunk / PKGBUILD
blob4b11996674dccda438a90800031d666fcffb409e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=clutter-gtk
5 pkgver=1.8.4
6 pkgrel=3
7 pkgdesc="Clutter integration with GTK+"
8 url="https://gitlab.gnome.org/GNOME/clutter-gtk"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(clutter)
12 makedepends=(gobject-introspection gtk-doc git meson)
13 options=(debug)
14 _commit=77483ba46384adde76f6c4599eae77eeec852c56  # tags/1.8.4^0
15 source=("git+https://gitlab.gnome.org/GNOME/clutter-gtk.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build -Denable_docs=true
29   meson compile -C build
32 package() {
33   meson install -C build --destdir "$pkgdir"
36 # vim:set sw=2 et: