upgpkg: sbcl 2.3.1-1
[arch-packages.git] / libnice / trunk / PKGBUILD
blob430019c4572fdade3cd2da8361278993c12e9434
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: William Díaz <wdiaz@archlinux.us>
5 pkgname=libnice
6 pkgver=0.1.21
7 pkgrel=1
8 pkgdesc="An implementation of the IETF's draft ICE (for p2p UDP data streams)"
9 url="https://nice.freedesktop.org"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(glib2 gnutls gupnp-igd)
13 makedepends=(gstreamer gtk-doc git meson gobject-introspection graphviz)
14 optdepends=('gstreamer: "nice" GStreamer plugin')
15 provides=(libnice.so)
16 _commit=3d9cae16a5094aadb1651572644cb5786a8b4e2d  # tags/0.1.21^0
17 source=("git+https://gitlab.freedesktop.org/libnice/libnice.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd libnice
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd libnice
29 build() {
30   arch-meson libnice build -D gtk_doc=enabled
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"
42 # vim:set sw=2 sts=-1 et: