archrelease: copy trunk to extra-x86_64
[arch-packages.git] / polari / trunk / PKGBUILD
blob210e4acfb1861784b6c2bdeded5e82a67b45ac9b
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=polari
4 pkgver=41.0
5 pkgrel=1
6 pkgdesc="An IRC Client for GNOME"
7 url="https://wiki.gnome.org/Apps/Polari"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(gjs gtk3 telepathy-glib telepathy-idle telepathy-mission-control
11          telepathy-logger gspell libsoup3)
12 makedepends=(gobject-introspection yelp-tools appstream-glib git meson)
13 groups=(gnome-extra)
14 _commit=0eab55718a07fcf7b3231ac565bf3f1651bfbe7e  # tags/41.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/polari.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"