1 # Maintainer: Felix Yan <felixonmars@gmail.com>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: dorphell <dorphell@archlinux.org>
8 pkgdesc="A wrapper library for generic spell checking"
10 url="https://abiword.github.io/enchant/"
13 makedepends=('aspell' 'hunspell' 'hspell' 'nuspell' 'libvoikko')
14 checkdepends=('unittestpp')
15 optdepends=('aspell: for aspell based spell checking support'
16 'hunspell: for hunspell based spell checking support'
17 'libvoikko: for libvoikko based spell checking support'
18 'hspell: for hspell based spell checking support'
19 'nuspell: for nuspell based spell checking support')
20 provides=('libenchant-2.so') # enchant_voikko.so enchant_nuspell.so enchant_hunspell.so enchant_hspell.so enchant_aspell.so)
21 source=("https://github.com/AbiWord/enchant/releases/download/v$pkgver/enchant-$pkgver.tar.gz")
22 sha512sums=('c97764a8f219033b440cbfb820624f54993b19ba1f38b56f20336889304f753c7c513008bb92cd1424bfbf528c2d473f35bef93d9140063612e3a270fd000deb')
31 ./configure --prefix=/usr \
34 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
45 make DESTDIR="$pkgdir" install