archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gsound / trunk / PKGBUILD
blobc0e75318db4ac113cf6760a1c544cf8c95b208cf
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
3 pkgname=gsound
4 pkgver=1.0.3
5 pkgrel=1
6 pkgdesc="Small library for playing system sounds"
7 url="https://wiki.gnome.org/Projects/GSound"
8 license=(LGPL)
9 arch=(x86_64)
10 depends=(glib2 libcanberra)
11 makedepends=(gobject-introspection vala git gtk-doc meson)
12 _commit=95d36d60cf53e0e7c5d5325e0f1f4fc765a611ae  # tags/1.0.3^0
13 source=("git+https://gitlab.gnome.org/GNOME/gsound.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/-/+/g'
21 prepare() {
22   cd $pkgname
25 build() {
26   arch-meson $pkgname build -D gtk_doc=true
27   meson compile -C build
30 check() {
31   meson test -C build --print-errorlogs
34 package() {
35   depends+=(libg{lib,object,io}-2.0.so libcanberra.so)
36   provides+=(libgsound.so)
38   meson install -C build --destdir "$pkgdir"