1 # Maintainer: Sébastien Luttringer
6 pkgdesc='RIP, OSPF, BGP, MPLS, BFD, Babel routing daemon'
8 url='https://bird.network.cz/'
10 backup=('etc/bird.conf')
11 depends=('glibc' 'readline' 'ncurses' 'libssh')
14 source=("https://bird.network.cz/download/$pkgname-$pkgver.tar.gz"
17 sha256sums=('8d895e3e311880e9efb888b4386cbec2f7e18bfb8334e8d4c8ca7c4341092638'
18 '4aa1e8d41229badd276aa3747f613e7df34761892add2258c63bdb5097dfeb2b')
22 # apply patch from the source array (should be a pacman feature)
24 for filename in "${source[@]}"; do
25 if [[ "$filename" =~ \.patch$ ]]; then
26 echo "Applying patch ${filename##*/}"
27 patch -p1 -N -i "$srcdir/${filename##*/}"
39 --localstatedir=/var \
40 --runstatedir=/run/$pkgname \
41 --docdir=/usr/share/doc/$pkgname
48 make DESTDIR="$pkgdir" install
51 install -D -m 644 "$srcdir/bird.service" "$pkgdir/usr/lib/systemd/system/bird.service"
54 # vim:set ts=2 sw=2 et: