1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
12 pkgdesc="A library for layout and rendering of text"
13 url="https://www.pango.org/"
30 _commit=25c27f452294f84044d5cc9f23b637193c7b4421 # tags/1.50.14^0
31 source=("git+https://gitlab.gnome.org/GNOME/pango.git#commit=$_commit")
36 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
48 arch-meson pango build "${meson_options[@]}"
49 meson compile -C build
52 # not running checks: validation breaks when deps
53 # (especially harfbuzz) don't match upstream CI
56 provides=(libpango{,cairo,ft2,xft}-1.0.so)
58 meson install -C build --destdir "$pkgdir"
60 mkdir -p doc/usr/share
61 mv {"$pkgdir",doc}/usr/share/doc
64 package_pango-docs() {
65 pkgdesc+=" (documentation)"
71 # vim:set sw=2 sts=-1 et: