archrelease: copy trunk to extra-x86_64
[arch-packages.git] / breezy / trunk / PKGBUILD
blob1e6773462319ec1e0a0a22e01bc071944d56af6b
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Adam Fontenot <adam.m.fontenot@gmail.com>
4 pkgname=breezy
5 pkgver=3.3.1
6 pkgrel=1
7 pkgdesc='A decentralized revision control system with support for Bazaar and Git file formats'
8 arch=(x86_64)
9 url=https://www.breezy-vcs.org/
10 license=(GPL2)
11 depends=(
12   python-configobj
13   python-fastbencode
14   python-merge3
15   python-patiencediff
16   python-six
17   python-yaml
19 makedepends=(
20   cython
21   git
22   python-dulwich
23   python-fastimport
24   python-gpgme
25   python-packaging
26   python-paramiko
27   python-setuptools
28   python-setuptools-gettext
29   python-setuptools-rust
31 optdepends=(
32   'python-dulwich: Git support'
33   'python-fastimport: Fastimport support'
34   'python-gpgme: PGP support'
35   'python-paramiko: access branches over SFTP'
37 provides=(bzr)
38 conflicts=(bzr)
39 replaces=(bzr)
40 _tag=ab1cedb426f675812998e7a05b528ea81e9201cc
41 source=(git+https://github.com/breezy-team/breezy.git#tag=${_tag})
42 sha256sums=(SKIP)
44 pkgver() {
45   cd breezy
46   git describe --tags | sed 's/brz-//; s/-/./g'
49 build() {
50   cd breezy
51   python setup.py build
54 package() {
55   cd breezy
56   python setup.py install --root="${pkgdir}" --install-data=usr/share --optimize=1 --skip-build
57   ln -s brz "${pkgdir}"/usr/bin/bzr # backwards compatibility
60 # vim: ts=2 sw=2 et: