1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Disassemble a pile of tiles by removing matching pairs"
8 url="https://wiki.gnome.org/Apps/Mahjongg"
11 depends=(gtk3 librsvg)
12 makedepends=(meson gobject-introspection yelp-tools appstream-glib git vala)
14 _commit=2214a09cdc2def8be5ae669a92aa31550e9f7cb4 # tags/3.38.3^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-mahjongg.git#commit=$_commit")
20 git describe --tags | sed 's/-/+/g'
28 arch-meson $pkgname build \
29 -D compile-schemas=disabled \
30 -D update-icon-cache=disabled
31 meson compile -C build
35 meson test -C build --print-errorlogs
39 DESTDIR="$pkgdir" meson install -C build