archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libpanel / repos / extra-x86_64 / PKGBUILD
blobb889264ab92041c54ac8560ccffaee2d33fe6cc8
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgbase=libpanel
4 pkgname=(libpanel libpanel-docs)
5 pkgver=1.0.2
6 pkgrel=1
7 pkgdesc="Dock/panel library for GTK 4"
8 url="https://gitlab.gnome.org/GNOME/libpanel"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(gtk4 libadwaita)
12 makedepends=(git meson vala gobject-introspection gi-docgen)
13 options=(debug)
14 _commit=57383af4bf075d290d891563a29a7482f9141026  # tags/1.0.2^0
15 source=("git+https://gitlab.gnome.org/GNOME/libpanel.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 build() {
24   local meson_options=(
25     -D install-examples=true
26   )
28   arch-meson $pkgname build "${meson_options[@]}"
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package_libpanel() {
37   provides=(libpanel-1.so)
39   meson install -C build --destdir "$pkgdir"
41   mkdir -p doc/usr/share
42   mv {"$pkgdir",doc}/usr/share/doc
45 package_libpanel-docs() {
46   pkgdesc+=" (documentation)"
47   depends=()
49   mv doc/* "$pkgdir"
52 # vim:set sw=2 sts=-1 et: