1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
4 pkgname=(libpanel libpanel-docs)
7 pkgdesc="Dock/panel library for GTK 4"
8 url="https://gitlab.gnome.org/GNOME/libpanel"
11 depends=(gtk4 libadwaita)
12 makedepends=(git meson vala gobject-introspection gi-docgen)
14 _commit=57383af4bf075d290d891563a29a7482f9141026 # tags/1.0.2^0
15 source=("git+https://gitlab.gnome.org/GNOME/libpanel.git#commit=$_commit")
20 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 -D install-examples=true
28 arch-meson $pkgname build "${meson_options[@]}"
29 meson compile -C build
33 meson test -C build --print-errorlogs
37 provides=(libpanel-1.so)
39 meson install -C build --destdir "$pkgdir"
41 mkdir -p doc/usr/share
42 mv {"$pkgdir",doc}/usr/share/doc
45 package_libpanel-docs() {
46 pkgdesc+=" (documentation)"
52 # vim:set sw=2 sts=-1 et: