1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Anatol Pomozov
3 # Contributor: JSpaces <jspace@unseen.is>
4 # Contributor: Triode <triode1@btinternet.com>
9 pkgdesc='The SoX Resampler library that aims to give fast and high quality results for any constant resampling ratio'
11 url='https://sourceforge.net/p/soxr/wiki/Home/'
15 source=("https://downloads.sourceforge.net/project/soxr/soxr-$pkgver-Source.tar.xz")
16 sha1sums=('32ea46b1a8c0c15f835422892d02fce8286aec3c')
19 if [[ -d build ]]; then
28 cmake ../soxr-${pkgver}-Source \
29 -DCMAKE_BUILD_TYPE='Release' \
30 -DCMAKE_INSTALL_PREFIX='/usr' \
31 -DBUILD_EXAMPLES='OFF' \
32 -DBUILD_SHARED_LIBS='ON' \
34 -DWITH_LSR_BINDINGS='ON' \
49 make DESTDIR="${pkgdir}" install
50 rm -rf "${pkgdir}"/usr/share/doc
51 install -Dm644 ../soxr-${pkgver}-Source/LICENCE -t "${pkgdir}"/usr/share/licenses/libsoxr/