archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libsoxr / repos / extra-x86_64 / PKGBUILD
blob7fdfb6e2caa077c707f7c2bd2e4815077091b920
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Anatol Pomozov
3 # Contributor: JSpaces <jspace@unseen.is>
4 # Contributor: Triode <triode1@btinternet.com>
6 pkgname=libsoxr
7 pkgver=0.1.3
8 pkgrel=2
9 pkgdesc='The SoX Resampler library that aims to give fast and high quality results for any constant resampling ratio'
10 arch=('x86_64')
11 url='https://sourceforge.net/p/soxr/wiki/Home/'
12 license=('GPL')
13 depends=('gcc-libs')
14 makedepends=('cmake')
15 source=("https://downloads.sourceforge.net/project/soxr/soxr-$pkgver-Source.tar.xz")
16 sha1sums=('32ea46b1a8c0c15f835422892d02fce8286aec3c')
18 prepare() {
19   if [[ -d build ]]; then
20     rm -rf build
21   fi
22   mkdir build
25 build() {
26   cd build
28   cmake ../soxr-${pkgver}-Source \
29     -DCMAKE_BUILD_TYPE='Release' \
30     -DCMAKE_INSTALL_PREFIX='/usr' \
31     -DBUILD_EXAMPLES='OFF' \
32     -DBUILD_SHARED_LIBS='ON' \
33     -DWITH_AVFFT='ON' \
34     -DWITH_LSR_BINDINGS='ON' \
35     -DWITH_OPENMP='ON' \
36     -DWITH_PFFFT='ON'
37   make
40 check() {
41   cd build
43   make test
46 package() {
47   cd build
49   make DESTDIR="${pkgdir}" install
50   rm -rf "${pkgdir}"/usr/share/doc
51   install -Dm644 ../soxr-${pkgver}-Source/LICENCE -t "${pkgdir}"/usr/share/licenses/libsoxr/
54 # vim: ts=2 sw=2 et: