OCaml 4.14.0 rebuild
[arch-packages.git] / aisleriot / repos / extra-x86_64 / PKGBUILD
blob00930febd85b2584820e48cf8e5ce7c8d6ea140f
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=aisleriot
4 pkgver=3.22.23
5 pkgrel=2
6 pkgdesc="A collection of patience games written in guile scheme"
7 url="https://wiki.gnome.org/Apps/Aisleriot"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(guile gtk3 librsvg libcanberra dconf)
11 makedepends=(git meson yelp-tools appstream-glib)
12 optdepends=('pysolfc: PySol card sets'
13             'pysolfc-cardsets: PySol card sets')
14 options=(!debug)  # https://bugs.archlinux.org/task/74486
15 _commit=730f7feb480e1b69cce0a7b333c998db6cf9b4c5  # tags/3.22.23^0
16 source=("git+https://gitlab.gnome.org/GNOME/aisleriot.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build \
30     -D theme_kde=false \
31     -D theme_pysol=true \
32     -D theme_pysol_path=/usr/share/PySolFC
33   meson compile -C build
36 check() {
37   meson test -C build --print-errorlogs
40 package() {
41   meson install -C build --destdir "$pkgdir"
44 # vim:set sw=2 et: