1 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
8 pkgdesc="A GNU tool for automatically creating Makefiles"
11 url="https://www.gnu.org/software/automake"
13 depends=('perl' 'bash')
14 makedepends=('autoconf')
15 checkdepends=('dejagnu' 'gcc-fortran' 'java-environment' 'vala' 'emacs' 'cscope'
16 'expect' 'ncompress' 'gettext' 'lzip' 'zip' 'sharutils' 'help2man'
17 # disable TeX tests for now, lots of them fail and need upstream
18 # fixes for current texlive release
19 #'texlive-bin' 'texinfo'
20 'python' 'python-virtualenv')
21 source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig})
22 sha512sums=('3084ae543aa3fb5a05104ffb2e66cfa9a53080f2343c44809707fd648516869511500dba50dae67ff10f92a1bf3b5a92b2a0fa01cda30adb69b9da03994d9d88'
24 validpgpkeys=('E1622F96D2BB4E58018EEF9860F906016E407573' # Stefano Lattarini
25 'F2A38D7EEB2B66405761070D0ADEE10094604D37' # Mathieu Lirzin
26 '155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
29 cd "${srcdir}/${pkgname}-${pkgver}"
30 ./configure --build=$CHOST --prefix=/usr
35 cd "${srcdir}/${pkgname}-${pkgver}"
40 cd "${srcdir}/${pkgname}-${pkgver}"
41 make DESTDIR="${pkgdir}" install