OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-characters / repos / extra-x86_64 / PKGBUILD
blob2565c9879dae454f55f4ff5ed8d38f081a15055a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-characters
5 pkgver=42.0
6 pkgrel=1
7 pkgdesc="A character map application"
8 arch=(x86_64)
9 url="https://gitlab.gnome.org/GNOME/gnome-characters"
10 license=(GPL2)
11 depends=(gjs gtk4 libunistring gnome-desktop-4 emoji-font libadwaita)
12 makedepends=(meson gobject-introspection appstream-glib git gperf)
13 groups=(gnome)
14 options=(debug)
15 _commit=e0b22aecba4cd63e5936a097c7ba7e645c0e27e5  # tags/42.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnome-characters.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"