OCaml 4.14.0 rebuild
[arch-packages.git] / libglib-testing / trunk / PKGBUILD
blob2f77829298b4b6d0f489fb96c66bf1d3c19a4f76
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=libglib-testing
4 pkgver=0.1.1
5 pkgrel=1
6 pkgdesc="Test harnesses and mock classes for GLib"
7 url="https://gitlab.gnome.org/pwithnall/libglib-testing"
8 license=(LGPL2.1)
9 arch=(x86_64)
10 depends=(glib2 dbus)
11 makedepends=(git meson gtk-doc)
12 options=(debug)
13 _commit=e326f73a7139c5e54fcf926896ae6e4cc899a1a7  # tags/0.1.1^0
14 source=("git+https://gitlab.gnome.org/pwithnall/libglib-testing.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   depends+=(libg{lib,object,io}-2.0.so)
37   provides+=(libglib-testing-${pkgver%%.*}.so)
39   meson install -C build --destdir "$pkgdir"