1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
4 pkgname=(librest librest-docs)
7 pkgdesc="Library for accessing RESTful web services"
8 url="https://gitlab.gnome.org/GNOME/librest"
11 depends=(glib2 libxml2 libsoup3 json-glib)
12 makedepends=(gobject-introspection git meson gi-docgen vala)
13 _commit=85bd00adfa6e06d3426ce7c9007e68e62f51be14 # tags/0.9.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/librest.git#commit=$_commit")
19 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 git tag -d 1.0.0 # Fixup tags
28 arch-meson librest build -D soup2=false
29 meson compile -C build
33 meson test -C build --print-errorlogs
37 depends+=(libg{lib,object,io}-2.0.so libxml2.so libsoup-3.0.so
39 provides+=(librest{,-extras}-1.0.so)
41 meson install -C build --destdir "$pkgdir"
43 mkdir -p doc/usr/share
44 mv {"$pkgdir",doc}/usr/share/doc
47 package_librest-docs() {
48 pkgdesc+=" (documentation)"