OCaml 4.14.0 rebuild
[arch-packages.git] / librest / trunk / PKGBUILD
blob98cc78640e7afc145c4189e91458b95f4841fe63
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgbase=librest
4 pkgname=(librest librest-docs)
5 pkgver=0.9.0
6 pkgrel=1
7 pkgdesc="Library for accessing RESTful web services"
8 url="https://gitlab.gnome.org/GNOME/librest"
9 arch=(x86_64)
10 license=(LGPL2.1)
11 depends=(glib2 libxml2 libsoup3 json-glib)
12 makedepends=(gobject-introspection git meson gi-docgen vala)
13 _commit=85bd00adfa6e06d3426ce7c9007e68e62f51be14  # tags/0.9.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/librest.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd librest
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd librest
24   git tag -d 1.0.0 # Fixup tags
27 build() {
28   arch-meson librest build -D soup2=false
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package_librest() {
37   depends+=(libg{lib,object,io}-2.0.so libxml2.so libsoup-3.0.so
38             libjson-glib-1.0.so)
39   provides+=(librest{,-extras}-1.0.so)
41   meson install -C build --destdir "$pkgdir"
43   mkdir -p doc/usr/share
44   mv {"$pkgdir",doc}/usr/share/doc
47 package_librest-docs() {
48   pkgdesc+=" (documentation)"
49   depends=()
51   mv doc/* "$pkgdir"
54 # vim:set sw=2 et: