1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Justin Davis (juster) <jrcd83@gmail.com>
4 pkgname=perl-mozilla-ca
7 pkgdesc="Mozilla's CA cert bundle in PEM format (using system CA store)"
9 license=('GPL2' 'LGPL2.1')
10 options=('!emptydirs')
11 depends=('perl' 'ca-certificates')
12 url='https://metacpan.org/release/Mozilla-CA'
13 source=("https://search.cpan.org/CPAN/authors/id/A/AB/ABH/Mozilla-CA-$pkgver.tar.gz")
14 sha512sums=('dc3d96de93b4b193861142afe5f8120a09faa0c105ba0cc2832e4d0c9f2611bbefa8046620a67267e6c374e5abde0ad829279f62acf8a7e411fd75c182745969')
18 # Use system CA store. Replacing the copy in the source tree so the test suite is actually run against it.
19 ln -sf /etc/ssl/certs/ca-certificates.crt lib/Mozilla/CA/cacert.pem
24 perl Makefile.PL INSTALLDIRS=vendor
35 make install DESTDIR="$pkgdir"
37 # Replace CA store here again because the symlink was installed as a file
38 ln -sf /etc/ssl/certs/ca-certificates.crt "$pkgdir"/usr/share/perl5/vendor_perl/Mozilla/CA/cacert.pem
41 # vim:set ts=2 sw=2 et: