upgpkg: sbcl 2.2.4-1
[arch-packages.git] / python-wrapt / trunk / PKGBUILD
blob2e8b8466b0e8b113764399556d13931c86681dcb
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Troy C < rstrox -ta yahoo -tod com >
4 pkgname=python-wrapt
5 pkgver=1.14.0
6 pkgrel=1
7 pkgdesc="A Python module for decorators, wrappers and monkey patching"
8 arch=("x86_64")
9 url="https://pypi.python.org/pypi/wrapt"
10 license=("BSD")
11 depends=('python')
12 makedepends=('python-setuptools')
13 checkdepends=('python-pytest')
14 source=("https://github.com/GrahamDumpleton/wrapt/archive/$pkgver/$pkgname-$pkgver.tar.gz")
15 sha512sums=('ef31279873688208bb17d875a3bbdba3d506f5d9febeae28f1bdb740830395d86aa21dcbe747d592f098b745e5a599c352e122a642f923eab0eb39a30f19695d')
17 build() {
18   cd wrapt-$pkgver
19   python setup.py build
22 check() {
23   cd wrapt-$pkgver
24   PYTHONPATH="$PWD/build/lib.linux-$CARCH-3.10:$PYTHONPATH" py.test
27 package() {
28   cd wrapt-$pkgver
29   python setup.py install --root="$pkgdir" --optimize=1
30   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE