upgpkg: sbcl 2.2.4-1
[arch-packages.git] / syntax-highlighting / trunk / PKGBUILD
blob35f6b1a24fe5e4e17b8b5a0789bf3b7bc0b5a587
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=syntax-highlighting
5 pkgver=5.93.0
6 pkgrel=1
7 pkgdesc='Syntax highlighting engine for structured text and code'
8 arch=(x86_64)
9 url='https://community.kde.org/Frameworks'
10 license=(GPL2)
11 depends=(qt5-base)
12 makedepends=(extra-cmake-modules qt5-declarative qt5-xmlpatterns qt5-tools qt5-doc doxygen)
13 optdepends=('qt5-declarative: QML bindings')
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('ebdb51f8922d2bc97457c7df376e6600d5ee9805fdc1ac7f7d6be35a3fec711b'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
19 options=(debug)
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF \
24     -DQRC_SYNTAX=OFF \
25     -DBUILD_QCH=ON
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build