OCaml 4.14.0 rebuild
[arch-packages.git] / evolution-ews / repos / extra-x86_64 / PKGBUILD
blobdf186f991520a84fa99e6d0bd64e2c0905d61128
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=evolution-ews
5 pkgver=3.44.4
6 pkgrel=1
7 pkgdesc="MS Exchange integration through Exchange Web Services"
8 url="https://wiki.gnome.org/Apps/Evolution/EWS"
9 arch=(x86_64)
10 license=(LGPL2.1)
11 depends=(libmspack evolution)
12 makedepends=(git intltool python cmake ninja systemd)
13 options=(debug)
14 _commit=fa856850b74c653bba0e1dbf183e402cf26ff9ed  # tags/3.44.4^0
15 source=("git+https://gitlab.gnome.org/GNOME/evolution-ews.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   cmake -S $pkgname -B build -G Ninja \
29     -DCMAKE_INSTALL_PREFIX=/usr \
30     -DLIBEXEC_INSTALL_DIR=/usr/lib \
31     -DSYSCONF_INSTALL_DIR=/etc
32   cmake --build build
35 package() {
36   DESTDIR="$pkgdir" cmake --install build