1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
5 pkgname=(pango pango-docs)
9 pkgdesc="A library for layout and rendering of text"
10 url="https://www.pango.org/"
13 depends=(libthai cairo libxft harfbuzz fribidi)
14 makedepends=(gobject-introspection help2man git meson gi-docgen)
16 _commit=641d8a2b056621fd1f1d5d58e6a9e4dbdfe8e7ae # tags/1.50.8^0
17 source=("git+https://gitlab.gnome.org/GNOME/pango.git#commit=$_commit")
22 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 arch-meson pango build -D gtk_doc=true
31 meson compile -C build
34 # not running checks: validation breaks when deps
35 # (especially harfbuzz) don't match upstream CI
38 provides=(libpango{,cairo,ft2,xft}-1.0.so)
40 meson install -C build --destdir "$pkgdir"
42 mkdir -p doc/usr/share
43 mv {"$pkgdir",doc}/usr/share/doc
46 package_pango-docs() {
47 pkgdesc+=" (documentation)"