archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pango / trunk / PKGBUILD
blobb9a734a81e9c4690366ce6cc18d2048ca8f16d86
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgbase=pango
5 pkgname=(pango pango-docs)
6 pkgver=1.50.3
7 pkgrel=1
8 epoch=1
9 pkgdesc="A library for layout and rendering of text"
10 url="https://www.pango.org/"
11 arch=(x86_64)
12 license=(LGPL)
13 depends=(libthai cairo libxft harfbuzz fribidi)
14 makedepends=(gobject-introspection help2man git meson gi-docgen)
15 checkdepends=(ttf-dejavu cantarell-fonts)
16 _commit=26aadb2508f9022cbfc72e73b558c6791f5d46d9  # tags/1.50.3^0
17 source=("git+https://gitlab.gnome.org/GNOME/pango.git#commit=$_commit"
18         fix-test.diff)
19 sha256sums=('SKIP'
20             'c4ad17910d51832ca15d5805e5b43af4c3de4de51cbf1880e616e12dc664895f')
22 pkgver() {
23   cd pango
24   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
27 prepare() {
28   cd pango
30   # Fix tests... seems to be a rounding error
31   git apply -3 ../fix-test.diff
34 build() {
35   arch-meson pango build -D gtk_doc=true
36   meson compile -C build
39 check() {
40   meson test -C build --print-errorlogs
43 package_pango() {
44   provides=(libpango{,cairo,ft2,xft}-1.0.so)
46   meson install -C build --destdir "$pkgdir"
48   mkdir -p doc/usr/share
49   mv {"$pkgdir",doc}/usr/share/doc
52 package_pango-docs() {
53   pkgdesc+=" (documentation)"
54   depends=()
56   mv doc/* "$pkgdir"
59 # vim:set sw=2 et: