1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
8 pkgdesc="Javascript Bindings for GNOME"
9 url="https://wiki.gnome.org/Projects/Gjs"
15 gobject-introspection-runtime
32 _commit=ff2e1b2f15cf246eb391a356a0ac0ea09fafc2e6 # tags/1.76.0^0
33 source=("git+https://gitlab.gnome.org/GNOME/gjs.git#commit=$_commit")
38 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
47 -D installed_tests=false
50 CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
51 CXXFLAGS="${CXXFLAGS/-O2/-O3} -fno-semantic-interposition"
52 LDFLAGS+=" -Wl,-Bsymbolic-functions"
54 arch-meson gjs build "${meson_options[@]}"
55 meson compile -C build
59 dbus-run-session xvfb-run -s '-nolisten local' \
60 meson test -C build --print-errorlogs
64 depends+=(libreadline.so)
65 meson install -C build --destdir "$pkgdir"
68 # vim:set sw=2 sts=-1 et: