db-move: moved linux-zen from [testing] to [extra] (x86_64)
[arch-packages.git] / gjs / trunk / PKGBUILD
blob06fc16f26c8dce8f028b686a0b98ab33bde9bdfd
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gjs
5 pkgver=1.76.0
6 pkgrel=1
7 epoch=2
8 pkgdesc="Javascript Bindings for GNOME"
9 url="https://wiki.gnome.org/Projects/Gjs"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(
13   cairo
14   dconf
15   gobject-introspection-runtime
16   js102
17   libsysprof-capture
18   readline
20 makedepends=(
21   dbus
22   git
23   gobject-introspection
24   meson
26 checkdepends=(
27   gtk3
28   gtk4
29   xorg-server-xvfb
31 provides=(libgjs.so)
32 _commit=ff2e1b2f15cf246eb391a356a0ac0ea09fafc2e6  # tags/1.76.0^0
33 source=("git+https://gitlab.gnome.org/GNOME/gjs.git#commit=$_commit")
34 sha256sums=('SKIP')
36 pkgver() {
37   cd gjs
38   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
41 prepare() {
42   cd gjs
45 build() {
46   local meson_options=(
47     -D installed_tests=false
48   )
50   CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
51   CXXFLAGS="${CXXFLAGS/-O2/-O3} -fno-semantic-interposition"
52   LDFLAGS+=" -Wl,-Bsymbolic-functions"
54   arch-meson gjs build "${meson_options[@]}"
55   meson compile -C build
58 check() {
59   dbus-run-session xvfb-run -s '-nolisten local' \
60     meson test -C build --print-errorlogs
63 package() {
64   depends+=(libreadline.so)
65   meson install -C build --destdir "$pkgdir"
68 # vim:set sw=2 sts=-1 et: