archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-console / trunk / PKGBUILD
blob5f94b2464d9a945faa7237509629305d6aca025f
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Fabian Bornschein <fabiscafe-cat-mailbox-dog-org>
3 # Contributor: Igor Dyatlov <dyatlov.igor@gmail.com>
5 pkgname=gnome-console
6 pkgver=43.0
7 pkgrel=1
8 pkgdesc="A simple user-friendly terminal emulator for the GNOME desktop"
9 url="https://gitlab.gnome.org/GNOME/console"
10 arch=(x86_64)
11 license=(GPL3)
12 depends=(libgtop libadwaita vte4)
13 makedepends=(appstream-glib git meson)
14 groups=(gnome)
15 _commit=cffddb1a7bbf8ad1b1616cc026909411e218db1a  # tags/43.0^0
16 source=("$pkgname::git+https://gitlab.gnome.org/GNOME/console.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   local meson_options=(
30     -D tests=true
31   )
33   arch-meson $pkgname build "${meson_options[@]}"
34   meson compile -C build
37 check() {
38   meson test -C build --print-errorlogs
41 package() {
42   meson install -C build --destdir "$pkgdir"
45 # vim:set sw=2 sts=-1 et: