archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ibus-typing-booster / trunk / PKGBUILD
blobb7dcae5da1d1b5cd76d50d3c65f52ae1a159e623
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=ibus-typing-booster
4 pkgver=2.22.4
5 pkgrel=1
6 pkgdesc="Predictive input method for the IBus platform"
7 url="https://mike-fabian.github.io/ibus-typing-booster/"
8 arch=(any)
9 license=(
10   Apache
11   GPL3
13 depends=(
14   ibus
15   m17n-lib
16   python-dbus
17   python-gobject
18   python-pyenchant
19   sqlite
21 makedepends=(git)
22 _commit=94d5b14aef811c3c3683526755303a4c63c4d9de  # tags/2.22.4
23 source=("git+https://github.com/mike-fabian/ibus-typing-booster#commit=$_commit")
24 b2sums=('SKIP')
26 pkgver() {
27   cd $pkgname
28   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
31 prepare() {
32   cd $pkgname
33   autoreconf -fvi
36 build() {
37   cd $pkgname
38   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
39     --libexecdir=/usr/lib/ibus
40   make
43 package() {
44   cd $pkgname
45   make DESTDIR="$pkgdir" install
47   cd "$pkgdir/usr/share/$pkgname/data"
48   gzip -nf --best *.{txt,json} annotations{,Derived}/*.xml
51 # vim:set sw=2 sts=-1 et: