archrelease: copy trunk to extra-x86_64
[arch-packages.git] / autoconf / trunk / PKGBUILD
blobc20d6d44dfe3f11af721c60a0fefd322eca89a40
1 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: Andreas Radke <andyrtr@archlinux.org>
5 pkgname=autoconf
6 pkgver=2.71
7 pkgrel=1
8 pkgdesc="A GNU tool for automatically configuring source code"
9 arch=('any')
10 license=('GPL2' 'GPL3' 'custom')
11 url="https://www.gnu.org/software/autoconf"
12 groups=('base-devel')
13 depends=('awk' 'm4' 'diffutils' 'perl' 'sh')
14 checkdepends=('gcc-fortran')
15 options=('debug')
16 source=("https://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig})
17 md5sums=('12cfa1687ffa2606337efe1a64416106'
18          'SKIP')
19 validpgpkeys=('82F854F3CE73174B8B63174091FCC32B6769AA64')  # Zack Weinberg
22 build() {
23         cd "${pkgname}-${pkgver}"
24         ./configure --prefix=/usr
25         make
28 check() {
29         cd "${pkgname}-${pkgver}"
30         make check
33 package() {
34         cd "${pkgname}-${pkgver}"
35         make DESTDIR="${pkgdir}" install
37         # license exception
38         install -Dm644 COPYING.EXCEPTION "$pkgdir"/usr/share/licenses/autoconf/COPYING.EXCEPTION
40         # remove unwanted file
41         rm -f "$pkgdir"/usr/share/info/standards.info