archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-maps / repos / extra-x86_64 / PKGBUILD
blob03119744da43d35cd77f2dfd631425cf44c6b473
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-maps
5 pkgver=41.4
6 pkgrel=1
7 pkgdesc="A simple GNOME 3 maps application"
8 url="https://wiki.gnome.org/Apps/Maps"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(geocode-glib geoclue gjs libchamplain libgee folks gfbgraph libhandy)
12 makedepends=(gobject-introspection git meson yelp-tools)
13 groups=(gnome)
14 _commit=3de5ab7ba3b1d4544450686230e023fbd37322c3  # tags/v41.4^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-maps.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"