OCaml 4.14.0 rebuild
[arch-packages.git] / gspell / trunk / PKGBUILD
blob1ab028c8104995a7e49fc159ad7d9c4c7cba7a2f
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gspell
5 pkgver=1.10.0
6 pkgrel=2
7 pkgdesc="Spell-checking library for GTK applications"
8 url="https://gitlab.gnome.org/GNOME/gspell"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(glib2 gtk3 enchant icu)
12 makedepends=(gobject-introspection vala gtk-doc autoconf-archive git)
13 options=(debug)
14 _commit=59d9cad6f3d1923d87b4ef0352a6539cd6aac52e  # tags/1.10.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/gspell.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd gspell
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd gspell
25   NOCONFIGURE=1 ./autogen.sh
28 build() {
29   cd gspell
30   ./configure  --prefix=/usr --enable-gtk-doc
31   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
32   make
35 package(){
36   depends+=(libg{lib,object,io}-2.0.so libpango-1.0.so libgtk-3.so
37             libenchant-2.so libicuuc.so)
38   provides+=("libgspell-${pkgver%%.*}.so")
40   cd gspell
41   make DESTDIR="$pkgdir" install