OCaml 4.14.0 rebuild
[arch-packages.git] / libreoffice-fresh / trunk / PKGBUILD
blob7db78c640d0c1a492f3e59426c5593b69c871f66
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Maintainer: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
4 # Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
5 # Note: These are for Arch Linux use ONLY. For your own distribution, please
6 # get your own set of keys. Feel free to contact foutrelis@archlinux.org for
7 # more information.
8 _google_default_client_id=413772536636.apps.googleusercontent.com
9 _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
11 pkgbase=libreoffice-fresh
12 pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
13 _LOver=7.3.5.2
14 pkgver=7.3.5
15 pkgrel=1
16 arch=('x86_64')
17 license=('LGPL3')
18 url="https://www.libreoffice.org/"
19 makedepends=('curl>=7.20.0' 'hunspell>=1.2.8' 'python>=3.7' 'libwpd>=0.9.2' 'libwps'
20         'neon>=0.28.6' 'pango' 'nspr' 'libjpeg' 'libxrandr' 'libgl' 'dbus-glib'
21         'libxslt' 'redland' 'hyphen' 'lpsolve' 'gcc-libs' 'sh' 'graphite' 'icu' 
22         'lcms2' 'poppler>=0.24.0' 'libvisio' 'libetonyek' 'libodfgen' 'libcdr'
23         'libmspub' 'harfbuzz-icu' 'nss' 'hicolor-icon-theme'
24         'desktop-file-utils' 'shared-mime-info' 'gst-plugins-base-libs'
25         'sane' 'perl-archive-zip' 'zip' 'unzip' 'unixodbc' 'ant'
26         'gperf' 'gtk3' 'qt5-base' 'plasma-framework' 'cppunit' 'beanshell' 'clucene'
27         'junit' 'libmythes' 'libwpg'  'java-environment=11' 'postgresql-libs' 'mariadb-libs' 'libgl'
28         'bluez-libs' 'gdb' 'doxygen'  'libatomic_ops'  'mdds'
29         'apr' 'serf' 'ttf-liberation' 'ttf-dejavu' 'ttf-carlito' 'libxinerama' 'libpagemaker' 'glm'
30         'libabw' 'libmwaw' 'libe-book' 'coin-or-mp' 'liblangtag' 'liborcus' 
31 #       'libexttextcat' 'libcmis' 'gobject-introspection' # 'libfbclient'
32         'libexttextcat' 'gobject-introspection' # 'libfbclient'
33         'libtommath' 'libzmf' 'gpgme' 'xmlsec' 'rxvt-unicode' 
34         'libepubgen' 'libfreehand' 'libqxp' 'libstaroffice'  'boost' 'libnumbertext'
35         'libcuckoo' 'abseil-cpp' 'clang' #'zxing-cpp'
36         'libffi' 'box2d' 'git'
38 options=('!lto') # using --enable-lto (for parallel link-time optimization)
39 _mirror="https://download.documentfoundation.org/libreoffice/src/${pkgver}"
40 #_mirror="https://dev-builds.libreoffice.org/pre-releases/src"
41 _additional_source_url="https://dev-www.libreoffice.org/src"
42 _additional_source_url2="https://dev-www.libreoffice.org/extern"
43 source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
44         ${_additional_source_url}/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
45         ${_additional_source_url}/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip # keep old bundled version, new system version ftbs
46         ${_additional_source_url}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
47         ${_additional_source_url}/0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
48         ${_additional_source_url}/language-subtag-registry-2021-03-05.tar.bz2
49         ${_additional_source_url}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
50         ${_additional_source_url}/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
51         ${_additional_source_url}/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
52         ${_additional_source_url}/pdfium-4699.tar.bz2
53         ${_additional_source_url}/dtoa-20180411.tgz
54         ${_additional_source_url}/lxml-4.1.1.tgz
55         ${_additional_source_url}/Firebird-3.0.7.33374-0.tar.bz2
56         ${_additional_source_url}/skia-m97-a7230803d64ae9d44f4e1282444801119a3ae967.tar.xz
57         ${_additional_source_url}/libcmis-0.5.2.tar.xz
58         ${_additional_source_url}/zxing-cpp-1.2.0.tar.gz
59         ${_additional_source_url2}/8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar  # for test suite
60         ${_additional_source_url2}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar # for test suite
61         ${_additional_source_url2}/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
62         ${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
63         make-pyuno-work-with-system-wide-module-install.diff
64         soffice-template.desktop.in 
65         libreoffice-fresh.sh libreoffice-fresh.csh)
66 noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
67            798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
68            a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
69            0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
70            language-subtag-registry-2021-03-05.tar.bz2
71            17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
72            d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
73            ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
74            pdfium-4699.tar.bz2
75            dtoa-20180411.tgz
76            lxml-4.1.1.tgz
77            Firebird-3.0.7.33374-0.tar.bz2
78            skia-m97-a7230803d64ae9d44f4e1282444801119a3ae967.tar.xz
79            libcmis-0.5.2.tar.xz
80            zxing-cpp-1.2.0.tar.gz
81            8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar  # for test suite
82            odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies-971c54fd38a968f5860014b44301872706f9e540.jar  # for test suite
83            f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
84            185d60944ea767075d27247c3162b3bc-unowinreg.dll
86 validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
87 sha256sums=('9b3e0db1ee153330ea05f04109bd817dbac2203d2eed83ef54be54d4c741e991'
88             'SKIP'
89             '9571c1953d7297d158dee8849f7e6315b102fb0cafb2280693e6064ef8013ca2'
90             'SKIP'
91             'd2fe9df14d1d7bbf16dd4c7f2fc9331622619d18caadf612d932496f52e146b2'
92             'SKIP'
93             '64585ac36a81291a58269ec5347e7e3e2e8596dbacb9221015c208191333c6e1'
94             '1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753'
95             '75823776fb51a9c526af904f1503a7afaaab900fba83eda64f8a41073724c870'
96             '983941d31ee8d366085cadf28db75eb1f5cb03ba1e5853b98f12f7f51c63b776'
97             'ce80e8face06bf2ada363e0c159e3f990c4116fdae9232ca43e6369aa82bf16a'
98             'd30b13f4ba2e3b6a2d4f020c0dee0a9fb9fc6fbcc2d561f36b78da4bf3802370'
99             '1b5b24f7bc543c0362b667692f78db8bab4ed6dafc6172f104d0bd3757d8a133'
100             '233f66e8d25c5dd971716d4200203a612a407649686ef3b52075d04b4c9df0dd'
101             'ee80fe0a3b20ef5c5babc494cd655d1b1a0bdec710acb04524789df500c563bf'
102             '0082d0684f7db6f62361b76c4b7faba19e0c7ce5cb8e36c4b65fea8281e711b4'
103             '940caef1ec7c78e0c34b0f6b94fe42d0f2022915ffc78643d28538a5cfd0f40e'
104             'acb85cedafa10ce106b1823fb236b1b3e5d942a5741e8f8435cc8ccfec0afe76'
105             '97e859e8467eca9d2441cd23079b61c2c3863b5687620f18cc31a9f966740177'
106             'd7b18d9602190e10d437f8a964a32e983afd57e2db316a07d87477a79f5000a2'
107             '653d9e44195d86cf64a36af9ff3a1978ec5599df3882439fefa56e7064f55e8a'
108             'f2443f27561af52324eee03a1892d9f569adc8db9e7bca55614898bc2a13a770'
109             '984f2a479df79e27e7b01a5815ac53ae64e07746b882262d8a64566494515504'
110             'f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140'
111             'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
112             'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
113             'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
114             'cd1b25ff390e436c6bffa65c6e12382236e3ccbf8d3aae51b1b59bcaed79fd8a'
115             'de20f36d45f0fecc2d94176dd3ec7226ab07fa8ffb9b0bc73c200349a9273de1')
117 prepare() {
119         cd libreoffice-$_LOver
121         # move external sources into place
122         mkdir "${srcdir}"/ext_sources && pushd "${srcdir}"/ext_sources
123         for source in "${noextract[@]}"; do
124                 ln -s "${srcdir}"/$source .
125         done
126         popd
127         
128         # unowinreg.dll must be a file not a symlink or the result will become a broken symlink
129         # /usr/share/libreoffice/sdk/classes/win/unowinreg.dll -> /build/libreoffice/src/185d60944ea767075d27247c3162b3bc-unowinreg.dll
130         rm "${srcdir}"/ext_sources/185d60944ea767075d27247c3162b3bc-unowinreg.dll
131         cp -f "${srcdir}"/185d60944ea767075d27247c3162b3bc-unowinreg.dll "${srcdir}"/ext_sources
133         # fix not upstreamable pyuno paths - FS#54250
134         patch -Np1 -i "${srcdir}"/make-pyuno-work-with-system-wide-module-install.diff
136         #use the CFLAGS but remove the LibO overridden ones
137         for i in $CFLAGS; do
138                 case "$i" in
139                         -O?|-pipe|-Wall|-g|-fexceptions) continue;;
140                 esac
141                 ARCH_FLAGS="$ARCH_FLAGS $i"
142         done
145 build() {
146         cd libreoffice-$_LOver
148         # strip -s from Makeflags in case you use it to shorten build logs
149         _MAKEFLAGS=${MAKEFLAGS/-s/}
151         # http://site.icu-project.org/download/61#TOC-Migration-Issues
152         CPPFLAGS+=' -DU_USING_ICU_NAMESPACE=1'
154         ./autogen.sh --with-extra-buildid="${pkgver}-${pkgrel}" \
155                 --with-vendor="Arch Linux" \
156                 --enable-split-app-modules \
157                 --with-parallelism=${_MAKEFLAGS/-j/} \
158                 --with-external-tar="${srcdir}/ext_sources" \
159                 --disable-fetch-external \
160                 --enable-release-build \
161                 --prefix=/usr --exec-prefix=/usr --sysconfdir=/etc \
162                 --libdir=/usr/lib --mandir=/usr/share/man \
163                 --with-lang="" \
164                 --with-help=html \
165                 --disable-avahi \
166                 --enable-dbus \
167                 --enable-evolution2\
168                 --enable-gio\
169                 --enable-gtk3-kde5 \
170                 --enable-kf5 \
171                 --enable-qt5 \
172                 --enable-gtk3 \
173                 --enable-introspection \
174                 --enable-lto \
175                 --enable-openssl \
176                 --enable-odk\
177                 --enable-python=system \
178                 --enable-scripting-beanshell \
179                 --enable-scripting-javascript \
180                 --disable-dconf \
181                 --disable-report-builder \
182                 --enable-ext-wiki-publisher \
183                 --enable-ext-nlpsolver \
184                 --without-fonts\
185                 --with-system-apr \
186                 --with-system-libcdr \
187                 --with-system-mdds\
188                 --without-myspell-dicts \
189                 --with-system-libvisio \
190                 --without-system-libcmis \
191                 --with-system-libmspub \
192                 --with-system-libexttextcat \
193                 --with-system-orcus \
194                 --with-system-liblangtag \
195                 --with-system-libodfgen \
196                 --with-system-libmwaw \
197                 --with-system-libetonyek \
198                 --with-system-libfreehand \
199                 --without-system-firebird \
200                 --without-system-zxing \
201                 --with-system-libtommath \
202                 --with-system-libatomic-ops \
203                 --with-system-libebook \
204                 --with-system-libabw \
205                 --with-system-coinmp \
206                 --with-system-dicts \
207                 --with-external-dict-dir=/usr/share/hunspell \
208                 --with-external-hyph-dir=/usr/share/hyphen \
209                 --with-external-thes-dir=/usr/share/mythes \
210                 --with-system-beanshell \
211                 --with-system-cppunit\
212                 --with-system-graphite\
213                 --with-system-glm \
214                 --with-system-libnumbertext \
215                 --with-system-libwpg \
216                 --with-system-libwps \
217                 --with-system-redland\
218                 --with-system-libzmf \
219                 --with-system-gpgmepp \
220                 --with-system-libstaroffice \
221                 --with-system-cuckoo \
222                 --with-system-serf \
223                 --with-jdk-home="/usr/lib/jvm/default" \
224                 --with-ant-home="/usr/share/ant"\
225                 --with-system-boost\
226                 --with-system-icu \
227                 --with-system-cairo \
228                 --with-system-libs \
229                 --with-system-mythes \
230                 --with-system-headers \
231                 --without-system-hsqldb \
232                 --with-system-clucene \
233                 --with-gdrive-client-id=${_google_default_client_id} \
234                 --with-gdrive-client-secret=${_google_default_client_secret} \
235                 --disable-dependency-tracking
237         touch src.downloaded
238         make build-nocheck
240         mkdir "${srcdir}"/fakeinstall
241         make DESTDIR="${srcdir}"/fakeinstall distro-pack-install
244 #check() {
245 #       cd "${srcdir}"/build
246 #       make check
249 package_libreoffice-fresh-sdk() {
250         pkgdesc="Software Development Kit for LibreOffice Fresh"
251         depends=('libreoffice-fresh' 'gcc-libs' 'sh' 'make' 'zip' 'gcc' 'java-environment')
252         provides=('libreoffice-sdk')
253         conflicts=('libreoffice-still-sdk')
255         for dir in $(grep -h ^%dir libreoffice-$_LOver/file-lists/sdk{,_doc}_list.txt); do
256                 install -dm755 "${pkgdir}"/${dir/\%dir/}
257         done
259         for file in $(grep -h -v ^%dir libreoffice-$_LOver/file-lists/sdk{,_doc}_list.txt); do
260                 dirname=$(dirname $file)
261                 [[ -d "${pkgdir}"/$dirname ]] || install -dm755 "${pkgdir}"/$dirname
262                 mv "${srcdir}"/fakeinstall/${file} "${pkgdir}"/$file
263         done
265         # fix environment path to keep compatibility with other java-environments
266         sed -i -e "s:\/usr\/lib\/jvm\/java-7-openjdk:\$J2SDKDIR:" \
267                 "${pkgdir}"/usr/lib/libreoffice/sdk/setsdkenv_unix.sh
269         # fix permissions
270         find "${pkgdir}"/usr/lib/libreoffice/sdk/examples -type f -exec chmod -x {} +
271         
272         # add LibreOfficeKit headers; FS#48066
273         install -dm755 "${pkgdir}"/usr/include/LibreOfficeKit
274         install -v -m644 "${srcdir}"/libreoffice-$_LOver/include/LibreOfficeKit/* "${pkgdir}"/usr/include/LibreOfficeKit
277 package_libreoffice-fresh() {
278         pkgdesc="LibreOffice branch which contains new features and program enhancements"
279         depends=('curl>=7.20.0' 'hunspell>=1.2.8' 'python>=3.7' 'libwpd>=0.9.2' 'libwps'
280                 'neon>=0.28.6' 'pango' 'nspr' 'libjpeg' 'libxrandr' 'libgl'
281                 'libxslt' 'redland' 'hyphen' 'lpsolve' 'gcc-libs' 'sh' 'graphite' 'icu' 
282                 'lcms2' 'poppler>=0.24.0' 'libvisio' 'libetonyek' 'libodfgen' 'libcdr'
283                 'libmspub' 'harfbuzz-icu' 'nss' 'clucene' 'hicolor-icon-theme'
284                 'desktop-file-utils' 'shared-mime-info' 'libpagemaker'
285                 'libxinerama' 'libabw' 'libmwaw' 'libe-book' 'libcups'
286                 #'liblangtag' 'libexttextcat' 'libcmis' 'liborcus' # 'libfbclient'
287                 'liblangtag' 'libexttextcat' 'liborcus' # 'libfbclient'
288                 'libtommath' 'libzmf' 'libatomic_ops' 'xmlsec' 'gpgme' 'libnumbertext'
289                 'libfreehand' 'libstaroffice' 'libepubgen' 'libqxp' 'libepoxy' 'box2d'
290                 #'zxing-cpp'
291                 'xdg-utils')
292         optdepends=('java-runtime:     adds java support'
293                 'java-environment: required by extension-wiki-publisher and extension-nlpsolver'
294                 'pstoedit:         translates PostScript and PDF graphics into other vector formats'
295                 'libmythes:        for use in thesaurus'
296                 'beanshell:       interactive java -- good for prototyping/macros'
297                 'libwpg:           library for importing and converting WordPerfect Graphics format'
298                 'sane:             for scanner access'
299                 'unixodbc:         adds ODBC database support'
300                 'gst-plugins-base-libs: for multimedia content, e.g. in Impress'
301                 'libpaper:         takes care of papersize'
302                 'postgresql-libs:  for postgresql-connector'
303                 'mariadb-libs:     for mysql-connector'
304                 'coin-or-mp:       required by the Calc solver'
305                 'gtk3:             for GTK3 integration'
306                 'kio:              for KF5 KDE desktop integration')
307         backup=(etc/libreoffice/sofficerc
308                 etc/libreoffice/bootstraprc
309                 etc/libreoffice/psprint.conf
310                 etc/profile.d/libreoffice-fresh.sh
311                 etc/profile.d/libreoffice-fresh.csh)
312         provides=('libreoffice' 'libreoffice-en-US')
313         conflicts=('libreoffice-still')
315         mv fakeinstall/* "${pkgdir}"/
317         # put configuration files into place
318         install -dm755 "${pkgdir}"/etc/libreoffice
319         install -m644 "${pkgdir}"/usr/lib/libreoffice/program/{bootstraprc,sofficerc} \
320                 "${pkgdir}"/etc/libreoffice/
321         install -m644 "${pkgdir}"/usr/lib/libreoffice/share/psprint/psprint.conf \
322                 "${pkgdir}"/etc/libreoffice/
324         # install dummy links to make them found by LibO
325         cd "${pkgdir}"/usr/lib/libreoffice/program/
326         ln -vsf /etc/libreoffice/{bootstraprc,sofficerc} .
327         cd "${pkgdir}"/usr/lib/libreoffice/share/psprint/
328         ln -vsf /etc/libreoffice/psprint.conf .
330         # allow to preset desired VLC
331         install -dm755 "${pkgdir}"/etc/profile.d
332         install -m644 "${srcdir}"/libreoffice-fresh.{sh,csh} "${pkgdir}"/etc/profile.d/
334         # make pyuno find its modules
335         install -dm755 "${pkgdir}"/usr/lib/python3.10/site-packages
336         ln -svf /usr/lib/libreoffice/program/uno.py \
337                 "${pkgdir}"/usr/lib/python3.10/site-packages/uno.py
338         ln -svf /usr/lib/libreoffice/program/unohelper.py \
339                 "${pkgdir}"/usr/lib/python3.10/site-packages/unohelper.py
340                 
341         # add a symlink required for gnome-documents; FS#51887
342         # https://lists.freedesktop.org/archives/libreoffice/2016-March/073787.html
343         ln -svf /usr/lib/libreoffice/program/liblibreofficekitgtk.so \
344                 "${pkgdir}"/usr/lib/liblibreofficekitgtk.so  
346         # cleanup
347         rm -rf "${pkgdir}"/usr/share/libreoffice/sdk
349         # add application descriptions
350         install -dm755 "${pkgdir}"/usr/share/metainfo
351         install -v -m644 "${srcdir}"/libreoffice-$_LOver/sysui/desktop/appstream-appdata/*.xml \
352                 "${pkgdir}"/usr/share/metainfo
354         # add kde filemanager templates; FS#61662 - file taken from Debian
355         install -dm755 "${pkgdir}"/usr/share/templates/.source
356         install -v -m644 "${srcdir}"/libreoffice-$_LOver/extras/source/shellnew/soffice.* \
357                 "${pkgdir}"/usr/share/templates/.source
359         cat "${srcdir}"/soffice-template.desktop.in \
360                 | sed -e "s/@APP@/Writer/" \
361                 | sed -e "s/@EXT@/odt/" \
362                 | sed -e "s/@TYPE@/text/" \
363                 > "${pkgdir}"/usr/share/templates/soffice.odt.desktop
364         cat "${srcdir}"/soffice-template.desktop.in \
365                 | sed -e "s/@APP@/Calc/" \
366                 | sed -e "s/@EXT@/ods/" \
367                 | sed -e "s/@TYPE@/spreadsheet/" \
368                 > "${pkgdir}"/usr/share/templates/soffice.ods.desktop
369         cat "${srcdir}"/soffice-template.desktop.in \
370                 | sed -e "s/@APP@/Impress/" \
371                 | sed -e "s/@EXT@/odp/" \
372                 | sed -e "s/@TYPE@/presentation/" \
373                 > "${pkgdir}"/usr/share/templates/soffice.odp.desktop
374         cat "${srcdir}"/soffice-template.desktop.in \
375                 | sed -e "s/@APP@/Draw/" \
376                 | sed -e "s/@EXT@/odg/" \
377                 | sed -e "s/@TYPE@/drawing/" \
378                 > "${pkgdir}"/usr/share/templates/soffice.odg.desktop
380         # make all i18n lang packages with help section ('1') available to
381         # fix "F1" not opening translated offline help opening in browser
382         # see also /usr/lib/libreoffice/help/en-US/langnames.js
383         echo "var languagesSet = new Set(['en-US','am','ar','ast','bg','bn',\
384         'bn-IN','bo','bs','ca','ca-valencia','cs','da','de','dz','el',\
385         'en-GB','en-ZA','eo','es','et','eu','fi','fr','gl','gu','he',\
386         'hi','hr','hu','id','is','it','ja','ka','km','ko','lo','lt','lv',\
387         'mk','nb','ne','nl','nn','om','pl','pt','pt-BR','ro','ru','si',\
388         'sid','sk','sl','sq','sv','ta','tg','tr','ug','uk','vi','zh-CN','zh-TW'])" \
389                 > "${pkgdir}"/usr/lib/libreoffice/help/languages.js