1 # Maintainer: Gaetan Bisson <bisson@archlinux.org>
2 # Contributor: kevin <kevin@archlinux.org>
3 # Contributor: John Proctor <jproctor@prium.net>
8 pkgdesc='Graph visualization software'
9 url='https://www.graphviz.org/'
12 depends=('libltdl' 'gd' 'librsvg' 'libxaw' 'ghostscript' 'pango' 'gts' 'gsfonts' 'libnsl' 'libpng')
13 makedepends=('swig' 'mono' 'guile' 'lua' 'ocaml>=4.14.0' 'perl' 'python' 'r' 'tk' 'qt5-base' 'gtk2')
14 optdepends=('mono: sharp bindings'
15 'guile: guile bindings'
17 'ocaml: ocaml bindings'
19 'python: python bindings'
23 'gtk2: gtk output plugin'
25 source=("https://gitlab.com/graphviz/graphviz/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
26 'ghostscript918.patch')
27 sha256sums=('f8cc576694ae93659f453b6b4a4c2f04572a90cfccdca2d4271f2e7c60bb3d60'
28 '0083d126e27f2223ec4226fc1d71c9c84106968a0fdf65de838aee1e4882bfdb')
33 cd "${srcdir}/${pkgname}-${pkgver}"
34 patch -p1 -i ../ghostscript918.patch
39 cd "${srcdir}/${pkgname}-${pkgver}"
41 export CXXFLAGS+=' -fPIC -fpermissive'
43 ./configure --prefix=/usr \
44 --enable-python3=yes --disable-python --enable-lefty
45 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool # Fix overlinking
50 cd "${srcdir}/${pkgname}-${pkgver}"
51 make DESTDIR="${pkgdir}" install
53 # fix symlink to symlink that doesn't get picked up by makepkg's zipman
54 ln -s gv2gxl.1.gz "${pkgdir}"/usr/share/man/man1/dot2gxl.1.gz
55 rm "${pkgdir}"/usr/share/man/man1/dot2gxl.1
57 # Deduplicates TCL libraries
58 cd "${pkgdir}/usr/lib/tcl8.6"
60 ln -s ../graphviz/tcl graphviz