upgpkg: sbcl 2.2.11-1
[arch-packages.git] / gnome-maps / repos / extra-x86_64 / PKGBUILD
blob946445f4d2918f40d6b7d6faf77496bd702f178e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-maps
5 pkgver=43.1
6 pkgrel=1
7 pkgdesc="A simple GNOME 3 maps application"
8 url="https://wiki.gnome.org/Apps/Maps"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gjs gtk4 libadwaita geocode-glib-2 geoclue libshumate librest libxml2
12          libgweather-4)
13 makedepends=(gobject-introspection git meson yelp-tools)
14 groups=(gnome)
15 options=(debug)
16 _commit=59374895d507728f1239300bad52682b9a7baed3  # tags/v43.1^0
17 source=("git+https://gitlab.gnome.org/GNOME/gnome-maps.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
29 build() {
30   arch-meson $pkgname build
31   meson compile -C build
34 check() {
35   meson test -C build --print-errorlogs
38 package() {
39   meson install -C build --destdir "$pkgdir"
42 # vim:set sw=2 sts=-1 et: