upgpkg: sbcl 2.2.11-1
[arch-packages.git] / libmspack / trunk / PKGBUILD
blob2a8d18967414ec2205036947af1c4707483b8bbe
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: AndyRTR <andyrtr@archlinux.org>
4 pkgname=libmspack
5 pkgver=0.10.1alpha
6 pkgrel=4
7 epoch=1
8 pkgdesc="A library for Microsoft compression formats"
9 url=https://www.cabextract.org.uk/libmspack/
10 arch=(x86_64)
11 license=(GPL)
12 depends=(glibc)
13 makedepends=(git)
14 provides=(libmspack.so)
15 options=(debug)
16 _commit=ec93021025f27983027c1bc101f674cb14a85c0d  # tags/v0.10.1alpha^0
17 source=("git+https://github.com/kyz/libmspack#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname/$pkgname
27   autoreconf -vfi
30 build() {
31   cd $pkgname/$pkgname
32   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
33     --disable-static
34   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
35   make
38 check() {
39   cd $pkgname/$pkgname
40   make check
43 package() {
44   cd $pkgname/$pkgname
45   make DESTDIR="$pkgdir" install
48 # vim:set sw=2 sts=-1 et: