archrelease: copy trunk to extra-any
[arch-packages.git] / plasma-firewall / trunk / PKGBUILD
blob6063f2f41e90411e8b1a67cf382bcca5cd8f8778
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=plasma-firewall
4 pkgver=5.27.0
5 pkgrel=1
6 pkgdesc='Control Panel for your system firewall'
7 arch=(x86_64)
8 url='https://kde.org/plasma-desktop/'
9 license=(GPL LGPL)
10 source=(https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
11 depends=(systemsettings)
12 makedepends=(extra-cmake-modules)
13 optdepends=('iproute2: netstat backend'
14             'firewalld: firewalld backend'
15             'ufw: ufw backend')
16 groups=(plasma)
17 sha256sums=('024ece9371843958b5ec9aa6ccce05221c20eb86335272c039138b1aa3c40a0a'
18             'SKIP')
19 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
20               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
21               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
22               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
24 build() {
25   cmake -B build -S $pkgname-$pkgver \
26     -DLIBEXEC_INSTALL_DIR=lib
27   cmake --build build
30 package() {
31   DESTDIR="$pkgdir" cmake --install build