package/aubio: add libsndfile optional dependency
[buildroot-gz.git] / package / cwiid / cwiid.mk
blob0cfc77479e8fd57462954a3ffb8faf74aee34b85
1 ################################################################################
3 # cwiid
5 ################################################################################
7 CWIID_VERSION = 0.6.00
8 CWIID_SOURCE = cwiid-$(CWIID_VERSION).tgz
9 CWIID_SITE = http://abstrakraft.org/cwiid/downloads
10 CWIID_LICENSE = GPLv2+
11 CWIID_LICENSE_FILES = COPYING
13 CWIID_AUTORECONF = YES
14 CWIID_INSTALL_STAGING = YES
16 CWIID_DEPENDENCIES = host-pkgconf host-bison host-flex bluez_utils
18 # Disable python support. This disables the 2 following things:
19 # - wminput Python plugin support
20 # - cwiid Python module
21 CWIID_CONF_OPTS = --without-python --disable-ldconfig
23 ifeq ($(BR2_PACKAGE_CWIID_WMGUI),y)
24 CWIID_DEPENDENCIES += libgtk2 libglib2
25 CWIID_CONF_OPTS += --enable-wmgui
26 else
27 CWIID_CONF_OPTS += --disable-wmgui
28 endif
30 $(eval $(autotools-package))