1 ################################################################################
5 ################################################################################
8 CWIID_SOURCE
= cwiid-
$(CWIID_VERSION
).tgz
9 CWIID_SITE
= http
://abstrakraft.org
/cwiid
/downloads
10 CWIID_LICENSE
= GPLv2
+
11 CWIID_LICENSE_FILES
= COPYING
13 CWIID_AUTORECONF
= YES
14 CWIID_INSTALL_STAGING
= YES
16 CWIID_DEPENDENCIES
= host-pkgconf host-bison host-flex bluez_utils
18 # Disable python support. This disables the 2 following things:
19 # - wminput Python plugin support
20 # - cwiid Python module
21 CWIID_CONF_OPTS
= --without-python
--disable-ldconfig
23 ifeq ($(BR2_PACKAGE_CWIID_WMGUI
),y
)
24 CWIID_DEPENDENCIES
+= libgtk2 libglib2
25 CWIID_CONF_OPTS
+= --enable-wmgui
27 CWIID_CONF_OPTS
+= --disable-wmgui
30 $(eval
$(autotools-package
))