1 ################################################################################
5 ################################################################################
7 CLAMAV_VERSION
= 0.99.2
8 CLAMAV_SITE
= https
://www.clamav.net
/downloads
/production
10 CLAMAV_LICENSE_FILES
= COPYING COPYING.bzip2 COPYING.file COPYING.getopt \
11 COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.pcre COPYING.regex \
12 COPYING.unrar COPYING.zlib
13 CLAMAV_DEPENDENCIES
= \
17 $(if
$(BR2_NEEDS_GETTEXT_IF_LOCALE
),gettext
)
19 # mmap cannot be detected when cross-compiling, needed for mempool support
21 ac_cv_c_mmap_private
=yes \
24 # UCLIBC_HAS_FTS is disabled, therefore disable fanotify (missing fts.h)
26 --with-dbdir
=/var
/lib
/clamav \
27 --with-openssl
=$(STAGING_DIR
)/usr \
28 --with-zlib
=$(STAGING_DIR
)/usr \
37 ifeq ($(BR2_PACKAGE_BZIP2
),y
)
38 CLAMAV_DEPENDENCIES
+= bzip2
39 # autodetection gets confused if host has bzip2, so force it
41 ac_cv_libbz2_libs
=-lbz2 \
42 ac_cv_libbz2_ltlibs
=-lbz2
44 CLAMAV_CONF_OPTS
+= --disable-bzip2
47 ifeq ($(BR2_PACKAGE_LIBXML2
),y
)
48 CLAMAV_CONF_OPTS
+= --with-xml
=$(STAGING_DIR
)/usr
49 CLAMAV_DEPENDENCIES
+= libxml2
51 CLAMAV_CONF_OPTS
+= --disable-xml
54 ifeq ($(BR2_PACKAGE_LIBCURL
),y
)
55 CLAMAV_CONF_OPTS
+= --with-libcurl
=$(STAGING_DIR
)/usr
56 CLAMAV_DEPENDENCIES
+= libcurl
58 CLAMAV_CONF_OPTS
+= --without-libcurl
61 ifeq ($(BR2_PACKAGE_LIBICONV
),y
)
62 CLAMAV_CONF_OPTS
+= --with-iconv
63 CLAMAV_DEPENDENCIES
+= libiconv
65 CLAMAV_CONF_OPTS
+= --without-iconv
68 ifeq ($(BR2_PACKAGE_PCRE
),y
)
69 CLAMAV_CONF_OPTS
+= --with-pcre
=$(STAGING_DIR
)/usr
70 CLAMAV_DEPENDENCIES
+= pcre
72 CLAMAV_CONF_OPTS
+= --without-pcre
75 $(eval
$(autotools-package
))