package/xfont_font-cronyx-cyrillic: add hash file
[buildroot-gz.git] / package / clamav / clamav.mk
blob6a82d66ca9326b59af58f3a034a5665160dede60
1 ################################################################################
3 # clamav
5 ################################################################################
7 CLAMAV_VERSION = 0.99.2
8 CLAMAV_SITE = https://www.clamav.net/downloads/production
9 CLAMAV_LICENSE = GPLv2
10 CLAMAV_LICENSE_FILES = COPYING COPYING.bzip2 COPYING.file COPYING.getopt \
11 COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.pcre COPYING.regex \
12 COPYING.unrar COPYING.zlib
13 CLAMAV_DEPENDENCIES = \
14 host-pkgconf \
15 openssl \
16 zlib \
17 $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
19 # mmap cannot be detected when cross-compiling, needed for mempool support
20 CLAMAV_CONF_ENV = \
21 ac_cv_c_mmap_private=yes \
22 have_cv_ipv6=yes
24 # UCLIBC_HAS_FTS is disabled, therefore disable fanotify (missing fts.h)
25 CLAMAV_CONF_OPTS = \
26 --with-dbdir=/var/lib/clamav \
27 --with-openssl=$(STAGING_DIR)/usr \
28 --with-zlib=$(STAGING_DIR)/usr \
29 --disable-rpath \
30 --disable-clamav \
31 --disable-fanotify \
32 --disable-milter \
33 --disable-llvm \
34 --disable-clamdtop \
35 --enable-mempool
37 ifeq ($(BR2_PACKAGE_BZIP2),y)
38 CLAMAV_DEPENDENCIES += bzip2
39 # autodetection gets confused if host has bzip2, so force it
40 CLAMAV_CONF_ENV += \
41 ac_cv_libbz2_libs=-lbz2 \
42 ac_cv_libbz2_ltlibs=-lbz2
43 else
44 CLAMAV_CONF_OPTS += --disable-bzip2
45 endif
47 ifeq ($(BR2_PACKAGE_LIBXML2),y)
48 CLAMAV_CONF_OPTS += --with-xml=$(STAGING_DIR)/usr
49 CLAMAV_DEPENDENCIES += libxml2
50 else
51 CLAMAV_CONF_OPTS += --disable-xml
52 endif
54 ifeq ($(BR2_PACKAGE_LIBCURL),y)
55 CLAMAV_CONF_OPTS += --with-libcurl=$(STAGING_DIR)/usr
56 CLAMAV_DEPENDENCIES += libcurl
57 else
58 CLAMAV_CONF_OPTS += --without-libcurl
59 endif
61 ifeq ($(BR2_PACKAGE_LIBICONV),y)
62 CLAMAV_CONF_OPTS += --with-iconv
63 CLAMAV_DEPENDENCIES += libiconv
64 else
65 CLAMAV_CONF_OPTS += --without-iconv
66 endif
68 ifeq ($(BR2_PACKAGE_PCRE),y)
69 CLAMAV_CONF_OPTS += --with-pcre=$(STAGING_DIR)/usr
70 CLAMAV_DEPENDENCIES += pcre
71 else
72 CLAMAV_CONF_OPTS += --without-pcre
73 endif
75 $(eval $(autotools-package))