package/dhcp/S80dhcp-server: allow empty INTERFACES
[buildroot-gz.git] / package / dhcpcd / dhcpcd.mk
blob2d0cb0cd360572fb5f6d083396a244056873b29c
1 ################################################################################
3 # dhcpcd
5 ################################################################################
7 DHCPCD_VERSION = 6.9.4
8 DHCPCD_SOURCE = dhcpcd-$(DHCPCD_VERSION).tar.xz
9 DHCPCD_SITE = http://roy.marples.name/downloads/dhcpcd
10 DHCPCD_DEPENDENCIES = host-pkgconf
11 DHCPCD_LICENSE = BSD-2c
12 DHCPCD_LICENSE_FILES = dhcpcd.c
14 ifeq ($(BR2_STATIC_LIBS),y)
15 DHCPCD_CONFIG_OPTS += --enable-static
16 endif
18 ifeq ($(BR2_USE_MMU),)
19 DHCPCD_CONFIG_OPTS += --disable-fork
20 endif
22 define DHCPCD_CONFIGURE_CMDS
23 (cd $(@D); \
24 $(TARGET_CONFIGURE_OPTS) ./configure \
25 --os=linux \
26 --libexecdir=/lib/dhcpcd \
27 $(DHCPCD_CONFIG_OPTS) )
28 endef
30 define DHCPCD_BUILD_CMDS
31 $(TARGET_MAKE_ENV) $(MAKE) \
32 -C $(@D) all
33 endef
35 define DHCPCD_INSTALL_TARGET_CMDS
36 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install DESTDIR=$(TARGET_DIR)
37 endef
39 # NOTE: Even though this package has a configure script, it is not generated
40 # using the autotools, so we have to use the generic package infrastructure.
42 $(eval $(generic-package))