1 ################################################################################
5 ################################################################################
8 MUTT_SITE
= https
://bitbucket.org
/mutt
/mutt
/downloads
10 MUTT_LICENSE_FILES
= GPL
11 MUTT_DEPENDENCIES
= ncurses
12 MUTT_CONF_OPTS
= --disable-smtp
15 ifeq ($(BR2_PACKAGE_LIBICONV
),y
)
16 MUTT_DEPENDENCIES
+= libiconv
17 MUTT_CONF_OPTS
+= --enable-iconv
20 ifeq ($(BR2_PACKAGE_MUTT_IMAP
),y
)
21 MUTT_CONF_OPTS
+= --enable-imap
23 MUTT_CONF_OPTS
+= --disable-imap
26 ifeq ($(BR2_PACKAGE_MUTT_POP3
),y
)
27 MUTT_CONF_OPTS
+= --enable-pop
29 MUTT_CONF_OPTS
+= --disable-pop
32 # SSL support is only used by imap or pop3 module
33 ifneq ($(BR2_PACKAGET_MUTT_IMAP
)$(BR2_PACKAGE_MUTT_POP3
),)
34 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
35 MUTT_DEPENDENCIES
+= openssl
36 MUTT_CONF_OPTS
+= --with-ssl
=$(STAGING_DIR
)/usr
38 MUTT_CONF_OPTS
+= --without-ssl
41 MUTT_CONF_OPTS
+= --without-ssl
44 # Avoid running tests to check for:
45 # - target system is *BSD
46 # - C99 conformance (snprintf, vsnprintf)
47 # - behaviour of the regex library
48 # - if mail spool directory is world/group writable
49 # - we have a working libiconv
52 mutt_cv_c99_snprintf
=yes \
53 mutt_cv_c99_vsnprintf
=yes \
54 mutt_cv_regex_broken
=no \
55 mutt_cv_worldwrite
=yes \
56 mutt_cv_groupwrite
=yes \
57 mutt_cv_iconv_good
=yes \
58 mutt_cv_iconv_nontrans
=no
60 MUTT_CONF_OPTS
+= --with-mailpath
=/var
/mail
63 ln
-sf
/tmp
$(TARGET_DIR
)/var
/mail
65 MUTT_POST_INSTALL_TARGET_HOOKS
+= MUTT_VAR_MAIL
67 $(eval
$(autotools-package
))