website: update Free Electrons logo
[buildroot-gz.git] / package / iptables / iptables.mk
bloba8ebec88181aae844a457cb3c335c2497a2feb35
1 ################################################################################
3 # iptables
5 ################################################################################
7 IPTABLES_VERSION = 1.6.0
8 IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
9 IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables
10 IPTABLES_INSTALL_STAGING = YES
11 IPTABLES_DEPENDENCIES = host-pkgconf \
12 $(if $(BR2_PACKAGE_LIBNETFILTER_CONNTRACK),libnetfilter_conntrack)
13 IPTABLES_LICENSE = GPLv2
14 IPTABLES_LICENSE_FILES = COPYING
15 # Building static causes ugly warnings on some plugins
16 IPTABLES_CONF_OPTS = --libexecdir=/usr/lib --with-kernel=$(STAGING_DIR)/usr \
17 $(if $(BR2_STATIC_LIBS),,--disable-static)
18 # For 0002-iptables-add-xtables-config-parser.h-to-BUILT_SOURCES.patch
19 # and 0003-extensions-added-AR-substitution.patch
20 IPTABLES_AUTORECONF = YES
22 # For connlabel match
23 ifeq ($(BR2_PACKAGE_LIBNETFILTER_CONNTRACK),y)
24 IPTABLES_DEPENDENCIES += libnetfilter_conntrack
25 endif
27 # For nfnl_osf
28 ifeq ($(BR2_PACKAGE_LIBNFNETLINK),y)
29 IPTABLES_DEPENDENCIES += libnfnetlink
30 endif
32 # For iptables-compat tools
33 ifeq ($(BR2_PACKAGE_IPTABLES_NFTABLES),y)
34 IPTABLES_CONF_OPTS += --enable-nftables
35 IPTABLES_DEPENDENCIES += host-bison host-flex libmnl libnftnl
36 else
37 IPTABLES_CONF_OPTS += --disable-nftables
38 endif
40 # bpf compiler support and nfsynproxy tool
41 ifeq ($(BR2_PACKAGE_IPTABLES_BPF_NFSYNPROXY),y)
42 # libpcap is tricky for static-only builds and needs help
43 ifeq ($(BR2_STATIC_LIBS),y)
44 IPTABLES_LIBS_FOR_STATIC_LINK += `$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`
45 IPTABLES_CONF_OPTS += LIBS="$(IPTABLES_LIBS_FOR_STATIC_LINK)"
46 endif
47 IPTABLES_CONF_OPTS += --enable-bpf-compiler --enable-nfsynproxy
48 IPTABLES_DEPENDENCIES += libpcap
49 else
50 IPTABLES_CONF_OPTS += --disable-bpf-compiler --disable-nfsynproxy
51 endif
53 $(eval $(autotools-package))