1 ################################################################################
5 ################################################################################
7 CLAMAV_VERSION
= 0.99.2
8 CLAMAV_SITE
= https
://www.clamav.net
/downloads
/production
10 CLAMAV_LICENSE_FILES
= COPYING COPYING.bzip2 COPYING.file COPYING.getopt \
11 COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.pcre COPYING.regex \
12 COPYING.unrar COPYING.zlib
13 CLAMAV_DEPENDENCIES
= \
17 $(if
$(BR2_NEEDS_GETTEXT_IF_LOCALE
),gettext
)
19 # mmap cannot be detected when cross-compiling, needed for mempool support
21 ac_cv_c_mmap_private
=yes \
24 # UCLIBC_HAS_FTS is disabled, therefore disable fanotify (missing fts.h)
26 --with-dbdir
=/var
/lib
/clamav \
27 --with-openssl
=$(STAGING_DIR
)/usr \
28 --with-zlib
=$(STAGING_DIR
)/usr \
29 --disable-zlib-vcheck \
38 ifeq ($(BR2_PACKAGE_BZIP2
),y
)
39 CLAMAV_DEPENDENCIES
+= bzip2
40 # autodetection gets confused if host has bzip2, so force it
42 ac_cv_libbz2_libs
=-lbz2 \
43 ac_cv_libbz2_ltlibs
=-lbz2
45 CLAMAV_CONF_OPTS
+= --disable-bzip2
48 ifeq ($(BR2_PACKAGE_LIBXML2
),y
)
49 CLAMAV_CONF_OPTS
+= --with-xml
=$(STAGING_DIR
)/usr
50 CLAMAV_DEPENDENCIES
+= libxml2
52 CLAMAV_CONF_OPTS
+= --disable-xml
55 ifeq ($(BR2_PACKAGE_LIBCURL
),y
)
56 CLAMAV_CONF_OPTS
+= --with-libcurl
=$(STAGING_DIR
)/usr
57 CLAMAV_DEPENDENCIES
+= libcurl
59 CLAMAV_CONF_OPTS
+= --without-libcurl
62 ifeq ($(BR2_PACKAGE_LIBICONV
),y
)
63 CLAMAV_CONF_OPTS
+= --with-iconv
64 CLAMAV_DEPENDENCIES
+= libiconv
66 CLAMAV_CONF_OPTS
+= --without-iconv
69 ifeq ($(BR2_PACKAGE_PCRE
),y
)
70 CLAMAV_CONF_OPTS
+= --with-pcre
=$(STAGING_DIR
)/usr
71 CLAMAV_DEPENDENCIES
+= pcre
73 CLAMAV_CONF_OPTS
+= --without-pcre
76 $(eval
$(autotools-package
))