toolchain: bump Codescape IMG MIPS version to 2016.05-06
[buildroot-gz.git] / package / irssi / irssi.mk
blobe467f89890c7cb2dd574f708d9965fb8ff2a540c
1 ################################################################################
3 # irssi
5 ################################################################################
7 IRSSI_VERSION = 0.8.21
8 IRSSI_SOURCE = irssi-$(IRSSI_VERSION).tar.xz
9 # Do not use the github helper here. The generated tarball is *NOT* the
10 # same as the one uploaded by upstream for the release.
11 IRSSI_SITE = https://github.com/irssi/irssi/releases/download/$(IRSSI_VERSION)
12 IRSSI_LICENSE = GPLv2+
13 IRSSI_LICENSE_FILES = COPYING
14 IRSSI_DEPENDENCIES = host-pkgconf libglib2 ncurses
16 IRSSI_CONF_OPTS = \
17 --disable-glibtest \
18 --with-ncurses=$(STAGING_DIR)/usr \
19 --without-perl
21 ifeq ($(BR2_PACKAGE_OPENSSL),y)
22 IRSSI_CONF_OPTS += --enable-ssl
23 IRSSI_DEPENDENCIES += openssl
24 else
25 IRSSI_CONF_OPTS += --disable-ssl
26 endif
28 ifeq ($(BR2_PACKAGE_IRSSI_PROXY),y)
29 IRSSI_CONF_OPTS += --with-proxy
30 # If shared libs are disabled, 'proxy' has to go in the list of built-in
31 # modules.
32 ifeq ($(BR2_STATIC_LIBS),y)
33 IRSSI_CONF_OPTS += --with-modules=proxy
34 endif
35 else
36 IRSSI_CONF_OPTS += --without-proxy
37 endif # proxy
39 ifeq ($(BR2_PACKAGE_IRSSI_TRUE_COLOR),y)
40 IRSSI_CONF_OPTS += --enable-true-color
41 else
42 IRSSI_CONF_OPTS += --disable-true-color
43 endif
45 # Cross-compiling irssi with the perl interpreter enabled doesn't work
46 # yet. So, remove scripts as they are useless in that case.
47 define IRSSI_REMOVE_SCRIPTS
48 rm -rf $(TARGET_DIR)/usr/share/irssi/scripts/
49 endef
51 IRSSI_POST_INSTALL_TARGET_HOOKS += IRSSI_REMOVE_SCRIPTS
53 $(eval $(autotools-package))