1 ################################################################################
5 ################################################################################
7 ALLJOYN_BASE_REV
= 16.04
8 ALLJOYN_BASE_VERSION
= $(ALLJOYN_BASE_REV
).00
9 ALLJOYN_BASE_SOURCE
= alljoyn-base-
$(ALLJOYN_BASE_VERSION
).
tar.gz
11 https
://mirrors.kernel.org
/allseenalliance
/alljoyn
/$(ALLJOYN_BASE_REV
)
12 # See https://allseenalliance.org/alliance/ip-policy
13 ALLJOYN_BASE_LICENSE
= ISC
15 ALLJOYN_BASE_DEPENDENCIES
= host-scons alljoyn openssl
16 ALLJOYN_BASE_INSTALL_STAGING
= YES
18 ALLJOYN_BASE_CRYPTO
= openssl
20 # AllJoyn can be compiled in debug or release mode. By default,
21 # AllJoyn is built in debug mode.
22 ALLJOYN_BASE_VARIANT
= release
24 ALLJOYN_BASE_BINDINGS
= c
,cpp
26 # By setting openwrt for OS and CPU, AllJoyn cross-compilation can be finely
27 # tuned through TARGET_xxx options. All TARGET_xxx variables must be defined
28 # otherwise compilation will fail.
29 # CROSS_COMPILE option should not be used as it works only for linux/ARM.
30 ALLJOYN_BASE_OS
= openwrt
31 ALLJOYN_BASE_CPU
= openwrt
33 # AllJoyn install everything in this relative path
34 ALLJOYN_BASE_DISTDIR
= \
35 build
/$(ALLJOYN_OS
)/$(ALLJOYN_CPU
)/$(ALLJOYN_VARIANT
)/dist
37 ALLJOYN_BASE_SCONS_OPTS
= \
40 OS
=$(ALLJOYN_BASE_OS
) \
41 CPU
=$(ALLJOYN_BASE_CPU
) \
42 VARIANT
=$(ALLJOYN_BASE_VARIANT
) \
44 CRYPTO
=$(ALLJOYN_BASE_CRYPTO
) \
45 BINDINGS
=$(ALLJOYN_BASE_BINDINGS
) \
46 ALLJOYN_DISTDIR
="$(STAGING_DIR)"\
47 TARGET_CFLAGS
="$(TARGET_CFLAGS)" \
48 TARGET_CPPFLAGS
="$(TARGET_CPPFLAGS)" \
49 TARGET_LINKFLAGS
="$(TARGET_LINKFLAGS)" \
50 TARGET_CC
="$(TARGET_CC)" \
51 TARGET_CXX
="$(TARGET_CXX)" \
52 TARGET_LD
="$(TARGET_LD)" \
53 TARGET_LINK
="$(TARGET_CXX)" \
54 TARGET_AR
="$(TARGET_AR)" \
55 TARGET_RANLIB
="$(TARGET_RANLIB)" \
56 TARGET_PATH
="$(BR_PATH)"
58 ifeq ($(BR2_PACKAGE_ALLJOYN_BASE_CONTROLPANEL
), y
)
59 ALLJOYN_BASE_TARGETS
+= controlpanel
62 ifeq ($(BR2_PACKAGE_ALLJOYN_BASE_NOTIFICATION
), y
)
63 ALLJOYN_BASE_TARGETS
+= notification
66 ifeq ($(BR2_PACKAGE_ALLJOYN_BASE_ONBOARDING
), y
)
67 ALLJOYN_BASE_TARGETS
+= onboarding
70 define ALLJOYN_BASE_BUILD_CMDS
71 $(foreach target
,$(ALLJOYN_BASE_TARGETS
),\
72 cd
$(@D
)/$(target
); $(SCONS
) $(ALLJOYN_BASE_SCONS_OPTS
)
76 define ALLJOYN_BASE_INSTALL_STAGING_CMDS
77 $(foreach target
,$(ALLJOYN_BASE_TARGETS
),\
78 cp
-a
$(@D
)/$(target
)/$(ALLJOYN_BASE_DISTDIR
)/*/lib
/lib
* \
79 $(STAGING_DIR
)/usr
/lib
/
80 cp
-a
$(@D
)/$(target
)/$(ALLJOYN_BASE_DISTDIR
)/*/inc
/* \
81 $(STAGING_DIR
)/usr
/include/
85 define ALLJOYN_BASE_INSTALL_TARGET_CMDS
86 $(foreach target
,$(ALLJOYN_BASE_TARGETS
),\
87 cp
-a
$(@D
)/$(target
)/$(ALLJOYN_BASE_DISTDIR
)/*/lib
/lib
* \
88 $(TARGET_DIR
)/usr
/lib
/
92 $(eval
$(generic-package
))