nginx-nasxi: new package
[buildroot-gz.git] / package / wget / wget.mk
blob9cda76b6a213f001b885f1909a6a582ed6b5d96c
1 ################################################################################
3 # wget
5 ################################################################################
7 WGET_VERSION = 1.18
8 WGET_SOURCE = wget-$(WGET_VERSION).tar.xz
9 WGET_SITE = $(BR2_GNU_MIRROR)/wget
10 WGET_DEPENDENCIES = host-pkgconf
11 WGET_LICENSE = GPLv3+
12 WGET_LICENSE_FILES = COPYING
14 # Prefer full-blown wget over busybox
15 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
16 WGET_DEPENDENCIES += busybox
17 endif
19 ifeq ($(BR2_PACKAGE_GNUTLS),y)
20 WGET_CONF_OPTS += \
21 --with-ssl=gnutls \
22 --with-libgnutls-prefix=$(STAGING_DIR)
23 WGET_DEPENDENCIES += gnutls
24 endif
26 ifeq ($(BR2_PACKAGE_OPENSSL),y)
27 WGET_CONF_OPTS += --with-ssl=openssl --with-libssl-prefix=$(STAGING_DIR)
28 WGET_DEPENDENCIES += openssl
29 endif
31 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
32 WGET_DEPENDENCIES += util-linux
33 endif
35 # --with-ssl is default
36 ifneq ($(BR2_PACKAGE_GNUTLS),y)
37 ifneq ($(BR2_PACKAGE_OPENSSL),y)
38 WGET_CONF_OPTS += --without-ssl
39 endif
40 endif
42 $(eval $(autotools-package))