xorg-server: not available with musl on ARM
[buildroot-gz.git] / package / mutt / mutt.mk
blobcd44ca101df9791e4ef5ec409f040e2b84c321b9
1 ################################################################################
3 # mutt
5 ################################################################################
7 MUTT_VERSION = 1.7.1
8 MUTT_SITE = https://bitbucket.org/mutt/mutt/downloads
9 MUTT_LICENSE = GPLv2+
10 MUTT_LICENSE_FILES = GPL
11 MUTT_DEPENDENCIES = ncurses
12 MUTT_CONF_OPTS = --disable-smtp
13 MUTT_AUTORECONF = YES
15 ifeq ($(BR2_PACKAGE_LIBICONV),y)
16 MUTT_DEPENDENCIES += libiconv
17 MUTT_CONF_OPTS += --enable-iconv
18 endif
20 ifeq ($(BR2_PACKAGE_LIBIDN),y)
21 MUTT_DEPENDENCIES += libidn
22 MUTT_CONF_OPTS += --with-idn
23 else
24 MUTT_CONF_OPTS += --without-idn
25 endif
27 ifeq ($(BR2_PACKAGE_MUTT_IMAP),y)
28 MUTT_CONF_OPTS += --enable-imap
29 else
30 MUTT_CONF_OPTS += --disable-imap
31 endif
33 ifeq ($(BR2_PACKAGE_MUTT_POP3),y)
34 MUTT_CONF_OPTS += --enable-pop
35 else
36 MUTT_CONF_OPTS += --disable-pop
37 endif
39 # SSL support is only used by imap or pop3 module
40 ifneq ($(BR2_PACKAGET_MUTT_IMAP)$(BR2_PACKAGE_MUTT_POP3),)
41 ifeq ($(BR2_PACKAGE_OPENSSL),y)
42 MUTT_DEPENDENCIES += openssl
43 MUTT_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
44 else
45 MUTT_CONF_OPTS += --without-ssl
46 endif
47 else
48 MUTT_CONF_OPTS += --without-ssl
49 endif
51 # Avoid running tests to check for:
52 # - target system is *BSD
53 # - C99 conformance (snprintf, vsnprintf)
54 # - behaviour of the regex library
55 # - if mail spool directory is world/group writable
56 # - we have a working libiconv
57 MUTT_CONF_ENV += \
58 mutt_cv_bsdish=no \
59 mutt_cv_c99_snprintf=yes \
60 mutt_cv_c99_vsnprintf=yes \
61 mutt_cv_regex_broken=no \
62 mutt_cv_worldwrite=yes \
63 mutt_cv_groupwrite=yes \
64 mutt_cv_iconv_good=yes \
65 mutt_cv_iconv_nontrans=no
67 MUTT_CONF_OPTS += --with-mailpath=/var/mail
69 define MUTT_VAR_MAIL
70 ln -sf /tmp $(TARGET_DIR)/var/mail
71 endef
72 MUTT_POST_INSTALL_TARGET_HOOKS += MUTT_VAR_MAIL
74 $(eval $(autotools-package))